Payments issue
Incident Report for Airtasker
Resolved
This incident has been resolved.
Posted almost 2 years ago. Feb 09, 2017 - 11:42 AEDT
Monitoring
The issue has been resolved and we're currently monitoring.
Posted almost 2 years ago. Feb 09, 2017 - 11:33 AEDT
Identified
The issue has been identified and our payment provider is working on the solution.
Posted almost 2 years ago. Feb 09, 2017 - 11:11 AEDT
Investigating
We are currently experiencing issues with payments and working with our provider
Posted almost 2 years ago. Feb 09, 2017 - 10:09 AEDT