Credit Card Processing is currently unavailable
Incident Report for Airtasker
Resolved
This incident has been resolved.
Posted over 2 years ago. Nov 22, 2016 - 11:16 AEDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted over 2 years ago. Nov 22, 2016 - 11:04 AEDT
Identified
We have identified an issue with an upstream banking provider and are working with them to restore services.
Posted over 2 years ago. Nov 22, 2016 - 10:34 AEDT