Release payments are unavailable
Incident Report for Airtasker
Resolved
Payments are able to be released again.
Posted over 1 year ago. May 25, 2017 - 10:39 AEST
Investigating
Airtasker currently cannot release payments, we are working closely with our third-party providing to resolve the issue. More details to follow shortly.
Posted over 1 year ago. May 25, 2017 - 10:25 AEST