Payment outage
Incident Report for Airtasker
Resolved
Issue has now been resolved
Posted over 2 years ago. Aug 16, 2016 - 11:40 AEST
Investigating
Our payment provider is currently experience technical difficulties. We are working closely to have the service restored.
Posted over 2 years ago. Aug 16, 2016 - 11:04 AEST