Credit Card Processing is currently not available
Incident Report for Airtasker
Resolved
This incident has been resolved.
Posted over 2 years ago. Jan 13, 2017 - 13:27 AEDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted over 2 years ago. Jan 13, 2017 - 11:40 AEDT
Investigating
We're working with our payment provider to resolve the issue.
Posted over 2 years ago. Jan 13, 2017 - 10:12 AEDT