Airtasker is currently unavailable.
Incident Report for Airtasker
Resolved
This incident has been resolved
Posted almost 2 years ago. Sep 11, 2017 - 16:43 AEST
Identified
Airtasker is currently unavailable. We have identified the issues and looking to restore services shortly.
Posted almost 2 years ago. Sep 11, 2017 - 16:32 AEST