Airtasker is currently unavailable
Incident Report for Airtasker
Resolved
This incident has been resolved.
Posted over 1 year ago. May 01, 2017 - 20:43 AEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted over 1 year ago. May 01, 2017 - 17:51 AEST
Identified
Airtasker is currently unavailable. We have identified the issues and looking to restore services shortly.
Posted over 1 year ago. May 01, 2017 - 17:33 AEST