Airtasker Application experiencing issues/slowness
Incident Report for Airtasker
Resolved
No further issues have been identified
Posted over 3 years ago. Jan 13, 2016 - 14:50 AEDT
Monitoring
The site is back up and running! We're monitoring further to ensure any niggling issues are sorted out
Posted over 3 years ago. Jan 13, 2016 - 14:22 AEDT
Identified
The issue has been identified and a fix is being implemented.
Posted over 3 years ago. Jan 13, 2016 - 14:02 AEDT
Investigating
We're experiencing issues due to a recent update to the application and are working on it right now to resolve. Please stay tuned
Posted over 3 years ago. Jan 13, 2016 - 13:48 AEDT