Payment issues
Incident Report for Airtasker
Resolved
This incident has been resolved.
Posted almost 2 years ago. Feb 10, 2017 - 14:31 AEDT
Investigating
We've identified payment issues with provider. We're currently investigating.
Posted almost 2 years ago. Feb 10, 2017 - 13:46 AEDT