Payout outage
Incident Report for Airtasker
Resolved
This incident has been resolved.
Posted about 2 years ago. Nov 17, 2016 - 13:11 AEDT
Investigating
Our payment provider is experiencing timeout issues again. We're working closely with them to resolve the issues.
Posted about 2 years ago. Nov 17, 2016 - 09:48 AEDT