Payment outage
Incident Report for Airtasker
Resolved
This incident has been resolved.
Posted over 2 years ago. Nov 15, 2016 - 22:10 AEDT
Investigating
The payment provider is currently experiencing issues and are currently looking into the issue.
Posted over 2 years ago. Nov 15, 2016 - 21:51 AEDT