Location error
Incident Report for Airtasker
Resolved
Location service is now operational.
Posted almost 3 years ago. Jun 27, 2016 - 17:41 AEST
Investigating
New users unable to create account due to location issues.
Posted almost 3 years ago. Jun 27, 2016 - 10:23 AEST